mirror of
https://github.com/Rudd-O/ansible-qubes.git
synced 2025-03-01 14:22:33 +01:00
44 lines
1.0 KiB
RPMSpec
44 lines
1.0 KiB
RPMSpec
%define debug_package %{nil}
|
|
|
|
%define mybuildnumber %{?build_number}%{?!build_number:1}
|
|
|
|
Name: ansible-qubes
|
|
Version: 0.0.1
|
|
Release: %{mybuildnumber}%{?dist}
|
|
Summary: Inter-VM program execution for Qubes OS AppVMs and StandaloneVMs
|
|
BuildArch: noarch
|
|
|
|
License: GPLv3+
|
|
URL: https://github.com/Rudd-O/ansible-qubes
|
|
Source0: https://github.com/Rudd-O/%{name}/archive/{%version}.tar.gz#/%{name}-%{version}.tar.gz
|
|
|
|
BuildRequires: make
|
|
BuildRequires: gawk
|
|
|
|
Requires: python2
|
|
|
|
%description
|
|
This package lets you execute programs between VMs as if it was SSH.
|
|
|
|
%prep
|
|
%setup -q
|
|
|
|
%build
|
|
# variables must be kept in sync with install
|
|
make DESTDIR=$RPM_BUILD_ROOT BINDIR=%{_bindir}
|
|
|
|
%install
|
|
rm -rf $RPM_BUILD_ROOT
|
|
# variables must be kept in sync with build
|
|
for target in install; do
|
|
make $target DESTDIR=$RPM_BUILD_ROOT BINDIR=%{_bindir}
|
|
done
|
|
|
|
%files
|
|
%attr(0755, root, root) %{_bindir}/*
|
|
%doc README.md
|
|
|
|
%changelog
|
|
* Sun Jul 09 2017 Manuel Amador (Rudd-O) <rudd-o@rudd-o.com>
|
|
- Initial release.
|